最新消息:

Apache 缓存

建站 5104浏览

Apache 的 Expires 和 Cache-Control 模块包含控制缓存的信息。这些模块需要和 Apache 一起编译。虽然它们已经包含在发布版本中,但默认并没有启用。确定相应模块已经被启用的方法是:找到 httpd 程序并运行 httpd -l 会列出可用模块,要用的模块是 mod_expires 和 mod_headers。Apache 一旦启用了相应模块,就可以在 .htaccess 文件或者服务器的 access.conf 文件中,通过 mod_expires 设置副本过期时间了,包括设置控制应答时的 Expires 头内容和 Cache-Control 头的 max-age 指令,代码如下:

ExpiresActive On
ExpiresByType image/gif "access plus 1 month"
ExpiresByType image/jpg "access plus 1 month"
ExpiresByType image/jpeg "access plus 1 month"
ExpiresByType image/x-icon "access plus 1 month"
ExpiresByType image/bmp "access plus 1 month"
ExpiresByType image/png "access plus 1 month"
ExpiresByType text/html "access plus 30 minutes"
ExpiresByType text/css "access plus 30 minutes"
ExpiresByType text/txt "access plus 30 minutes"
ExpiresByType text/js "access plus 30 minutes"
ExpiresByType application/x-javascript "access plus 30 minutes"
ExpiresByType application/x-shockwave-flash "access plus 30 minutes"

也可用以下代码进行设置:

<ifmodule mod_expires.c>
 <filesmatch "\.(jpg|gif|png|css|js)$">
 ExpiresActive onExpiresDefault "access plus 1 year"
 </filesmatch>
</ifmodule>

设置 Expires 后,系统会自动输出 Cache-Control 的 max-age 信息,关于 Expires 详细内容可以查看 Apache 官方文档。

如果在 Windows 系统下使用 Apache,建议到 http://www.apachelounge.com/download/ 处下载改进的 Apache 服务器以及相关的缓存组件。Apache lounge 是 Apache 的改进版,在性能、稳定性和内存管理上都超过基于 VC 6 编译的 Apache 官方版本。Apache lounge 版本随着 Apache 官方版本同步更新,所以不需要担心版本和安全问题。

好了,Apache 缓存 就分享到这里,非常感谢你的来访。如果你喜欢本站,请不要忘记收藏本站,以便下次继续访问;也可以 关注站长微博 随时获取最新动态。你的支持就是我最大的动力!

转载请注明:爱维科斯 » Apache 缓存

支付宝打赏支付宝打赏 微信打赏微信打赏

如果文章对你有帮助,欢迎点击上方按钮打赏作者